Mobile Application Error Submitting miles
Incident Report for Motus LLC
Resolved
This incident has been resolved.
Posted Apr 01, 2024 - 15:31 EDT
Monitoring
We have identified and resolved the issue and are monitoring the system.
Posted Apr 01, 2024 - 12:52 EDT
Update
We are continuing to investigate this issue.
Posted Apr 01, 2024 - 10:24 EDT
Update
We are aware of the concern you are experiencing with our mobile app and submitting miles. You can submit your miles by logging into your account at www.motus.com. Our technical team is working on it right now.

We apologize for the inconvenience during this submission period.
Posted Apr 01, 2024 - 10:24 EDT
Investigating
We are aware of the concern you are experiencing with our mobile app and submitting miles. Our technical team is working on it right now.
We apologize for the inconvenience during this submission period.
Posted Apr 01, 2024 - 10:17 EDT
This incident affected: Mobile Applications.