Customer Care phone systems are down

Incident Report for Motus LLC

Resolved

Issue with our phone vendor has been resolved.
Posted Jan 04, 2023 - 18:29 EST

Identified

We are working with our phone vendor and the issue is being resolved. If you are not able to reach us, please try again later.
Posted Jan 04, 2023 - 15:26 EST

Update

We are continuing to investigate this issue.
Posted Jan 04, 2023 - 15:03 EST

Investigating

The phone system used to reach Motus Customer Care is down
Posted Jan 04, 2023 - 15:00 EST
This incident affected: Member Services Phone Support and Customer Care Phone Support.