We're experiencing a partial outage that is impacting access to the mobile app and motus.com.

Incident Report for Motus LLC

Resolved

This incident has been resolved.
Posted Aug 02, 2025 - 09:20 EDT

Monitoring

We have resolved the problem and are monitoring the our services for errors.
Posted Aug 01, 2025 - 22:33 EDT

Investigating

We are aware of a technical concern and our team is working to resolve it as quickly as possible. We will share live status updates here. Thank you for your patience!
Posted Aug 01, 2025 - 10:24 EDT
This incident affected: Motus.com and Mobile Applications.