Users receiving errors while uploading insurance documents

Incident Report for Motus LLC

Resolved

This issue has been resolved
Posted Feb 27, 2023 - 13:23 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 27, 2023 - 13:23 EST

Monitoring

We have found the issue and implemented a resolution. We are monitoring the situation right now to validate the fix.
Posted Feb 27, 2023 - 11:12 EST

Update

We are continuing to investigate this issue.
Posted Feb 27, 2023 - 11:12 EST

Investigating

We are investigating an issue where users are receiving errors when submitting their insurance documents. Our team is working on identifying the problem.
Posted Feb 27, 2023 - 10:09 EST
This incident affected: Motus.com.