Resolved - Motus.com and Mobile Application Outage

Incident Report for Motus LLC

Resolved

Full access has been restored to the site and mobile application. You will now be able to sign in as normal.
Posted Jul 17, 2023 - 13:00 EDT